読者です 読者をやめる 読者になる 読者になる

ImageMagickをRPMからインストールするときに表示された依存関係

[root@localhost redmine]# rpm -Uvh ftp://ftp.u-aizu.ac.jp/pub/graphics/image/ImageMagick/imagemagick.org/linux/CentOS/i386/ImageMagick-6.8.0-8.i386.rpm
Retrieving ftp://ftp.u-aizu.ac.jp/pub/graphics/image/ImageMagick/imagemagick.org/linux/CentOS/i386/ImageMagick-6.8.0-8.i386.rpm
error: Failed dependencies:
        libfftw3.so.3 is needed by ImageMagick-6.8.0-8.i386
        libltdl.so.3 is needed by ImageMagick-6.8.0-8.i386
        libMagick.so.10 is needed by (installed) ImageMagick-devel-6.2.8.0-15.el5_8.i386
        libWand.so.10 is needed by (installed) ImageMagick-devel-6.2.8.0-15.el5_8.i386
        ImageMagick = 6.2.8.0-15.el5_8 is needed by (installed) ImageMagick-devel-6.2.8.0-15.el5_8.i386
[root@localhost redmine]# rpm -Uvh ftp://ftp.u-aizu.ac.jp/pub/graphics/image/ImageMagick/imagemagick.org/linux/CentOS/i386/ImageMagick-devel-6.8.0-8.i386.rpm
Retrieving ftp://ftp.u-aizu.ac.jp/pub/graphics/image/ImageMagick/imagemagick.org/linux/CentOS/i386/ImageMagick-devel-6.8.0-8.i386.rpm
error: Failed dependencies:
        ImageMagick = 6.8.0-8 is needed by ImageMagick-devel-6.8.0-8.i386
        freetype-devel is needed by ImageMagick-devel-6.8.0-8.i386
        jasper-devel is needed by ImageMagick-devel-6.8.0-8.i386
        libfftw3.so.3 is needed by ImageMagick-devel-6.8.0-8.i386
        libltdl.so.3 is needed by ImageMagick-devel-6.8.0-8.i386